Jump to content
  • 1

Help! My Server is Broken!


Question

Hi - 

I own a small Minehut server and recently have been having problems with some aspects of the server. For one, nobody on my server can open iron doors or enter wooden doors when opened and wooden doors sometimes split, and redstone seems to have stopped working. For some reason, water also stopped flowing. Another thing: All Item Frames have disappeared along with any items inside. At the bottom of this post should be a screenshot of all my plugins, if it helps.

P.S. My friend is also playing on the server, and says that it looks different to him than it does to me.

 

 

Screen Shot 2019-10-30 at 12.52.08 PM.png

Link to post
Share on other sites

19 answers to this question

Recommended Posts

  • 0
1 hour ago, Star said:

You can try running the command "/stoplag -c" to fix this.  If that doesn't work, try removing plugins one by one to see if they may be the problem (Start with the ones you aren't sure about to try and save some time.)

Thanks for the help, but I can't use the command. It doesn't seem to exist. Is there a plugin I need to install for it?

Link to post
Share on other sites
  • 0
1 minute ago, Star said:

Possibly gravy or GravityTubes, not sure about any of the other ones though.

Well, gravy is for creating graves that keep your items if you have a gravy token, and GravityTubes is for creating elevator shafts. I've had them for ages, and nothing like this has ever happened before. It might be something to do with lag or 

Link to post
Share on other sites
  • 0

Another thing:

Here's an excerpt from my logs when I try to open an iron door:

[20:55:09] [Server thread/WARN]: [Arconix] Task #73 for Arconix v2.0.0 generated an exception
java.lang.NullPointerException: null
    at com.songoda.arconix.plugin.Arconix.doSave(Arconix.java:62) ~[?:?]
    at org.bukkit.craftbukkit.v1_14_R1.scheduler.CraftTask.run(CraftTask.java:84) ~[spigot.jar:git-Paper-206]
    at org.bukkit.craftbukkit.v1_14_R1.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:452) ~[spigot.jar:git-Paper-206]
    at net.minecraft.server.v1_14_R1.MinecraftServer.b(MinecraftServer.java:1165) ~[spigot.jar:git-Paper-206]
    at net.minecraft.server.v1_14_R1.DedicatedServer.b(DedicatedServer.java:417) ~[spigot.jar:git-Paper-206]
    at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:1092) ~[spigot.jar:git-Paper-206]
    at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:919) ~[spigot.jar:git-Paper-206]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_212]
[20:55:23] [WebSocketConnectReadThread-239/INFO]: [Matrix] [Cloud] Connection closed: 1006 reason: 
[20:55:41] [Craft Scheduler Thread - 31/INFO]: [Matrix] Trying to reconnect to the cloud service...
[20:55:41] [WebSocketConnectReadThread-312/INFO]: [Matrix] [Cloud] Connected to the Cloud Service
 

This might have nothing to do with opening the door, but I noticed it after I updated the log.

One part of it in particular seems to be related to it:

[20:57:23] [WebSocketConnectReadThread-312/INFO]: [Matrix] [Cloud] Connection closed: 1006 reason: 
[20:57:41] [Craft Scheduler Thread - 27/INFO]: [Matrix] Trying to reconnect to the cloud service...
[20:57:41] [WebSocketConnectReadThread-336/INFO]: [Matrix] [Cloud] Connected to the Cloud Service

This group of information threads seem to have something to do with it.

Edit: Check this out:

[21:00:09] [Server thread/WARN]: [Arconix] Task #73 for Arconix v2.0.0 generated an exception
java.lang.NullPointerException: null
    at com.songoda.arconix.plugin.Arconix.doSave(Arconix.java:62) ~[?:?]
    at org.bukkit.craftbukkit.v1_14_R1.scheduler.CraftTask.run(CraftTask.java:84) ~[spigot.jar:git-Paper-206]
    at org.bukkit.craftbukkit.v1_14_R1.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:452) ~[spigot.jar:git-Paper-206]
    at net.minecraft.server.v1_14_R1.MinecraftServer.b(MinecraftServer.java:1165) ~[spigot.jar:git-Paper-206]
    at net.minecraft.server.v1_14_R1.DedicatedServer.b(DedicatedServer.java:417) ~[spigot.jar:git-Paper-206]
    at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:1092) ~[spigot.jar:git-Paper-206]
    at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:919) ~[spigot.jar:git-Paper-206]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_212]
[21:01:23] [WebSocketConnectReadThread-336/INFO]: [Matrix] [Cloud] Connection closed: 1006 reason: 

For some reason different plugins keep disconnecting and Arconix seems to keep generating exceptions. Maybe something about my particular selection of plugins or the fact that I have so many plugins is breaking the server?

 

Edited by gusbrowninc
needed to add to post
Link to post
Share on other sites
  • 0
10 minutes ago, Star said:

It seems that the plugin Arconix causes the issue. Try uninstalling that, it may fix it.

Well, I tried that, but it seems that isn't it. I can't find any errors now when I open doors either, so maybe that just had nothing to do with it.

Link to post
Share on other sites
  • 0

Hewwo

Try to repair your files. You can do this by going into the Danger Zone in the Dashboard and clicking Repair Files. 

image.png.6fbdc96d9912d111f7c98f7c47e04038.png

Hope this helps, have a good one !

Edited by Kezdero

- 💗 - 

Member - Sometime in 2018

Pro - 2019

<>

Minehut's Carbonara Connoisseur

 - 💗 - 

Link to post
Share on other sites
  • 0
On 10/31/2019 at 7:27 AM, Kezdero said:

Hewwo

Try to repair your files. You can do this by going into the Danger Zone in the Dashboard and clicking Repair Files. 

image.png.6fbdc96d9912d111f7c98f7c47e04038.png

Hope this helps, have a good one !

I tried that. I think I might just delete the old server and make a new one. I've already downloaded the world.

Link to post
Share on other sites
  • 0

Topic Locked - Please don't necropost 

If you have any issues please make a new topic in the Help category. 

That one weird annoying mod guy

IGN: Anonymous192 (no I am not a hacker)
Discord: Anonymous192#0001 (Tag will might be changed if Skillsbo doesn't top me up with nitro ❤️)

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Joined On: 3 March 2018
[PATRON]: 3 October 2018
[Jr Mod]: 2 April 2020
[Jr Admin]: hmmmmmm when?

^^ I know the colours don't match lol ^^

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Put your own message here for $1k I need to pay my rent 

Link to post
Share on other sites
  • -1

This post belongs in the "Community Support" category. Please make sure you post in the correct place next time!

Moved to Community Support

Discord: thistle#1234
In Game: thistl

Minehut Community Support Member
(8/10/19)
Minehut Junior Moderator

(10/30/19)
Minehut Moderator
(12/30/19 - 07/11/20)
Reinstated
(09/19/20)

❤️

(05/19/21)

 

Link to post
Share on other sites
  • -1
17 minutes ago, Star said:

Yeah, the command requires WorldGuard, but if you don't have the command, it couldn't have have been enabled in the first place. You'll have to go through your plugins to find the issue.

Okay. Do you see any that plugins you are suspicious of from my screenshot?

Link to post
Share on other sites
  • -1
10 minutes ago, gusbrowninc said:

I think that maybe I just need to remake my server. Seems like it's permanently broken. No matter what I do it does not fix.

It seems that the plugin Arconix causes the issue. Try uninstalling that, it may fix it.

[VIP] 2019

[JR.MOD] 10/29/2019

[MOD] 12/30/2019

nerd3.png

ok.png

sure.png

q.png

Link to post
Share on other sites
  • -1

Please don't necropost.

@xMuel

Support  July 29, 2020 → November 3, 2020

► Helper November 3, 2020 → February 22, 2021

► Moderator February 22, 2021 → May 17, 2021

 I might not always respond to forum dms, however I am always contactable on discord (mig#0069)

Screen Shot 2020-03-20 at 5.23.33 pm.png

Link to post
Share on other sites
Guest
This topic is now closed to further replies.


×
×
  • Create New...