Jump to content

Skript GUI clicking items doesn't execute anymore


Recommended Posts

Hi, I made a skript GUI that runs teleport commands to set locations when the items are clicked. I used the tuske extension. My code worked before, but after I went offline and came back online, the code stopped working. The server was hibernating between my login sessions. Instead of leaving the item in the GUI and executing the command, the player just takes the item out of the inventory, like with a normal chest. The code is unchanged and reloading skript doesn't solve the problem. I tried someone else's GUI, and it ran into the same problem. Part of my code is given below.
Can anyone help me solve this?

Thanks in advance, Wander

Code:

on rightclick:
    player is holding end rod named "Apparation Wand":
        cancel event
        open virtual chest inventory with size 1 named "Apparation Destinations" to player
        format gui slot 0 of player with elytra named "Samantha" to run:
            make player execute command "/execute in overworld run tp 170.0 97 -47"

Link to comment
Share on other sites

Hey, that happens when you use /sk reload all.

Typing /sk reload all breaks tuske guis so you should never use it when you have them.

 

Also I moved this to skript discussion as it's related to skript, please next time ask in there for anything related to skript 😃

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...