Jump to content
  • 0

Opped players cannot hat "You need something you can wear in your hand"


Question

All current plugins:

Citizens
EpicRename
EssentialsChat
EssentialsWarpGUI
EssentialsX
Gsit
Libs Disguises
Permission Ex
ProtocalLib
Sentinel
WorldEdit

How do you allow played opped with /op [playername] to wear a hat? I have tried removing the essentials.hat.prevent-type.* but I'm either doing it wrong or it's not working. Please help.

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

What are You trying to wear on Your head?

Hello!
IGN✦ centralwtf
Gender★ he/him
==========================================

Owner★ Boxable, NetherBox, FishHype

 ==========================================

Joined★ 22.07.2019

Member -> VIP ★ 29.04.2020

 ==========================================

obraz_2021-04-08_103028.png.8fa96840c599c6ff81febf732163163f.png

 

 

Link to post
Share on other sites
  • 0

Literally anything. Helmets, Pumpkins, Glass, Etc. Nothing works. I can just place helmets and pumpkins in the helmet slot though.

Everyone else on the server who is not opped is able to /hat anything.

Link to post
Share on other sites
  • 0
2 minutes ago, Hanatu said:

All current plugins:

Citizens
EpicRename
EssentialsChat
EssentialsWarpGUI
EssentialsX
Gsit
Libs Disguises
Permission Ex
ProtocalLib
Sentinel
WorldEdit

How do you allow played opped with /op [playername] to wear a hat? I have tried removing the essentials.hat.prevent-type.* but I'm either doing it wrong or it's not working. Please help.

Looks like everything you did is perfect. The problem is, permissions won't work for you because you do not have Vault installed. Vault is required for plugins to communicate with each other regarding permissions. Should work if you install Vault and restart your server.

  • Like 1

Hello there! If you're reading this, hope you're having a wonderful day!

 

Feel free to contact me via Discord (CoolProgrammer#1920) for any help.

My DMs are always open for help.

You can also message via. forum messages for help.

1604908226_ScreenShot2021-01-28at10_32_28AM.png.2646ad6be239a9d0756a99e8e15602ab.png

Also, don't hesitate to leave a like on my post if I helped you in any way.

Link to post
Share on other sites
  • 0

I've installed Vault, restarted , and I've tried to remove the essentials.hat.prevent-type.* again but it doesn't seem to be working still
Am I getting a command wrong maybe?
I'm typing out /pex user [name] remove essentials.hat.prevent-type.*

Link to post
Share on other sites
  • 0
32 minutes ago, Hanatu said:

I've installed Vault, restarted , and I've tried to remove the essentials.hat.prevent-type.* again but it doesn't seem to be working still
Am I getting a command wrong maybe?
I'm typing out /pex user [name] remove essentials.hat.prevent-type.*

Cross-check that the configuration of PermissionsEX. Make sure that it's a negated permission.

Hello there! If you're reading this, hope you're having a wonderful day!

 

Feel free to contact me via Discord (CoolProgrammer#1920) for any help.

My DMs are always open for help.

You can also message via. forum messages for help.

1604908226_ScreenShot2021-01-28at10_32_28AM.png.2646ad6be239a9d0756a99e8e15602ab.png

Also, don't hesitate to leave a like on my post if I helped you in any way.

Link to post
Share on other sites
  • 0
On 5/4/2021 at 5:12 PM, CoolProgrammer said:

Cross-check that the configuration of PermissionsEX. Make sure that it's a negated permission.

Apologies for not responding but I will check rq

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...