Jump to content

Update Request - (SkUniversal)


EarthAgar
 Share

Recommended Posts

Can we please get a version downgrade for SkUniversal? The latest version doesn't support PlotSquared v4 anymore and the only real difference between latest (2.11.5) and the previously version that supports PlotSquared v4 (2.10) is Updates and Improvements to Parties support. If we downgrade to support PlotSquared v4 again then we can do all kinds of crazy cool things with it. I'm also willing to talk with the dev and bribe him to add Backwards compatibility but its unlikely he will do it, I'll try tho.




image.png.bb4e66f4fbb4c91f51a56041c5e7d68b.png
 

Link to comment
Share on other sites

  • Administrator

I would like to generally avoid downgrading plugin versions as this can cause issues for other users (for example if someone is using the Parties plugin, which looks to be available on Minehut). It is usually also not very sustainable as a solution since in the future, we will have to update when Minecraft updates anyway.

 

I think having PlotSquared v5 would be much better in this case. I put some priority on this to see if we can get it soon.

Link to comment
Share on other sites

23 hours ago, pop4959 said:

I would like to generally avoid downgrading plugin versions as this can cause issues for other users (for example if someone is using the Parties plugin, which looks to be available on Minehut). It is usually also not very sustainable as a solution since in the future, we will have to update when Minecraft updates anyway.

 

I think having PlotSquared v5 would be much better in this case. I put some priority on this to see if we can get it soon.

I do understand your reason but from a lot of sources it has been said that Minehut is not capable of getting v5 as the dev denied the proposal. I don't know if you guys have a system for checking the popularity of plugins or not but it would be nice to know if other users even use Parties plugin. My only argument is that the updates that you would be reverting are technically just improvements to its hook for Parties.

Link to comment
Share on other sites

  • Administrator
26 minutes ago, EarthAgar said:

I do understand your reason but from a lot of sources it has been said that Minehut is not capable of getting v5 as the dev denied the proposal. I don't know if you guys have a system for checking the popularity of plugins or not but it would be nice to know if other users even use Parties plugin. My only argument is that the updates that you would be reverting are technically just improvements to its hook for Parties.

 

I'm not sure where those rumors are from but I made a big push today to get PlotSquared v5 up (ironically right before you sent your message). This plugin is open source, but it had to be reviewed (and it's a huge plugin). You should be able to download it now.

 

I've separated them in the plugins panel as PlotSquared v4 (for people who still need the old version) and PlotSquared v5 for those looking to switch / use the new one instead.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...